Snyk Code Degradation

Incident Report for Snyk

Resolved

Snyk engineers monitored the environment after the mitigation was deployed and have observed normal operations. The Snyk Incident Response has been stood down.
Posted Jan 28, 2026 - 19:48 UTC

Monitoring

The mitigation deployment is complete. Snyk Engineers are monitoring the environment.
Posted Jan 28, 2026 - 18:47 UTC

Identified

Snyk engineers have identified the cause of the issue and have implemented a change to reduce its impact. Because the failures are intermittent, customers may rerun tests as a temporary workaround. We will keep you updated on our progress.
Posted Jan 28, 2026 - 18:13 UTC

Update

Our investigations remain ongoing.

We will keep you updated with our progress.
Posted Jan 28, 2026 - 15:05 UTC

Investigating

We're currently investigating service degradation affecting Snyk Code, within our app.snyk.io environment.

Customers may observe intermittent failures affecting the test service. This will impact actions such as PR Checks and CLI tests, among others.

The Snyk Incident Response has been invoked.
Posted Jan 28, 2026 - 12:32 UTC
This incident affected: SNYK-US-01 (app.snyk.io) (Snyk Code).