Degradation of Bitbucket Cloud integration services

Incident Report for Snyk

Update

We have deployed a fix that enables a workaround for project imports using the BitBucket Connect App. As this rolls out, you may experience temporary failures with these imports for up to 30 minutes. If you experience an issue, we recommend waiting a few minutes before trying again.
Posted Mar 23, 2026 - 14:05 UTC

Identified

During our monitoring phase, we have become aware that customers using Bitbucket Connect App integrations may be unable to import new repositories.

We are investigating this and will keep you updated on our progress.
Posted Mar 23, 2026 - 12:18 UTC

Monitoring

A fix has been implemented, and we are now monitoring to ensure services fully recover.
Posted Mar 23, 2026 - 08:26 UTC

Identified

Customers using the Bitbucket Cloud integrations may see degradation in service affecting any use of the Bitbucket Cloud integrations, including:

Creating/Editing Bitbucket Integration,
Listing repos for import,
Import (via UI or API)
Tests, Recurring Tests, PR Checks
Fix PRs


We have identified the cause of the issue and are working towards remediation.
Posted Mar 23, 2026 - 00:45 UTC
This incident affects: SNYK-US-01 (app.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source), SNYK-US-02 (app.us.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source), SNYK-EU-01 (app.eu.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source), SNYK-AU-01 (app.au.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source), and SNYK-GOV-01 (app.snykgov.io) (Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source).