We have identified the root cause of the incident and established that this affects only a small subset of customers.
We will be reaching out to those customers in due course. However, as a workaround, customers can re-import the affected projects.
The Snyk Incident Response has now been stood down.
Posted Dec 18, 2025 - 13:54 UTC
Update
Our investigation into the issue remains ongoing.
Customers may have noticed that webhooks were not correctly configured for projects imported from Bitbucket Cloud. This will affect actions such as test-on push, set-and-forget, pull request checks and /snyk fix, among others.
As a workaround, customers can initiate a re-import of affected projects, which will install the webhook correctly and resolve the issue.
We will keep you updated with our progress.
Posted Dec 16, 2025 - 11:41 UTC
Investigating
Our Engineers are aware of the degradation affecting Bitbucket Cloud integrations.
Some Customers who imported projects via Bitbucket Cloud between the 30th of November and the 11th of December may notice that webhooks haven't been properly installed.
The Snyk Incident Response has been invoked, and we are investigating.
Posted Dec 15, 2025 - 15:43 UTC
This incident affected: SNYK-US-01 (app.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source), SNYK-US-02 (app.us.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source), SNYK-EU-01 (app.eu.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source), SNYK-AU-01 (app.au.snyk.io) (Snyk AppRisk, Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source), and SNYK-GOV-01 (app.snykgov.io) (Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source).