Inconsistencies in data in Snyk reporting function.
Incident Report for Snyk
Resolved
We are satisfied that replacing the component has resolved this issue.
Posted Oct 27, 2021 - 14:42 UTC
Identified
We have been having an issue with a component in our reporting infrastructure, which is causing some inconsistencies in the data that customers may see in the reporting sections of our UI and from the reporting API.

We have replaced the component in our reporting that was causing the issue. This means that from 14:00 UTC today (14th Oct 2021), current reporting information should be correct, however some of the graphs in our reporting UI and historic counts data may continue to have issues until we have been able to fix all of the historic data. More information on the details of this can be found here https://go.snyk.io/Reporting-data-inconsistencies.html
Posted Oct 14, 2021 - 17:56 UTC
Update
We currently have an issue with a component in our reporting infrastructure, which is causing some inconsistencies in the data that customers may see in the reporting sections of our UI and from the reporting API.

For clarity, this issue is only in our reporting function, Snyk products are working as normal in terms of identifying and notifying customers of their vulnerabilities; the issue is in the roll up of this data into reporting.

We take this issue very seriously and are working hard to resolve the situation as soon as possible. We have identified what we believe is a viable solution, which we are implementing. We hope to have a plan by the end of Friday the 15th of October for resolving the problem. This web page has a more details https://go.snyk.io/Reporting-data-inconsistencies.html
Posted Oct 12, 2021 - 21:20 UTC
Update
We currently have an issue with a component in our reporting infrastructure, which is causing some inconsistencies in the data that customers may see in the reporting sections of our UI and from the reporting API.

For clarity, this issue is only in our reporting function, Snyk products are working as normal in terms of identifying and notifying customers of their vulnerabilities; the issue is in the roll up of this data into reporting.

We take this issue very seriously and are currently aggressively pursuing a number of options to resolve the situation, but unfortunately as yet do not have an outlook for reporting returning to normal. We will update this status as we have more news. This web page has a more details https://go.snyk.io/Reporting-data-inconsistencies.html
Posted Oct 11, 2021 - 11:02 UTC
Investigating
We currently have an issue with a component in our reporting infrastructure, which is causing some inconsistencies in the data that customers may see in the reporting sections of our UI and from the reporting API.

For clarity, this issue is only in our reporting function, Snyk products are working as normal in terms of identifying and notifying customers of their vulnerabilities; the issue is in the roll up of this data into reporting.

We take this issue very seriously and are currently aggressively pursuing a number of options to resolve the situation, but unfortunately as yet do not have an outlook for reporting returning to normal. We will update this status as we have more news.
Posted Oct 08, 2021 - 16:12 UTC