Elevated Snyk PR Checks Processing Time across Different SCMs

Incident Report for Snyk

Resolved

This incident has been resolved. Any PR Checks that have been hanging should be closed and reopened.
Posted Mar 12, 2026 - 03:32 UTC

Update

We are still investigating the cause of the delays, but have identified that this appears to be affecting only the customers on app.snyk.io.
Posted Mar 12, 2026 - 02:59 UTC

Investigating

Our Engineers have determined a degradation of PR/MR Checks that is causing delays for the processing times.

We are currently investigating the cause and will provide updates on scope of impact as our investigation proceeds.
Posted Mar 12, 2026 - 02:30 UTC
This incident affected: SNYK-GOV-01 (app.snykgov.io) (Snyk Code, Snyk Open Source), SNYK-US-01 (app.snyk.io) (Snyk Code, Snyk Open Source), SNYK-US-02 (app.us.snyk.io) (Snyk Code, Snyk Open Source), SNYK-EU-01 (app.eu.snyk.io) (Snyk Code, Snyk Open Source), and SNYK-AU-01 (app.au.snyk.io) (Snyk Code, Snyk Open Source).