Organization members page unavailable for Organizations that do not belong to Groups on the Snyk website
Incident Report for Snyk
Resolved
The fix has been deployed and verified.
Posted Dec 03, 2021 - 15:21 UTC
Identified
We have identified an issue where some users are experiencing a temporary outage on the Organization members page on the Snyk website, no other Snyk services should be affected.

This affects only Organizations that are not associated to Groups.

A fix is in progress.
Posted Dec 03, 2021 - 12:13 UTC