Free Users Unable to Sign up for Snyk

Incident Report for Snyk

Resolved

Our Engineers have deployed, and we are no longer observing issues affecting the sign-up process.

The Snyk Incident Response has now been stood down.
Posted Mar 16, 2026 - 15:26 UTC

Investigating

Our Engineers are currently investigating an issue which is affecting Free Users from signing up to the Snyk platform.

The Snyk Incident Response has been invoked. We will keep you updated with our progress.
Posted Mar 16, 2026 - 14:10 UTC
This incident affected: SNYK-US-01 (app.snyk.io) (Snyk Code, Snyk Container, Snyk IaC, Snyk Open Source).