Issue on External Service
Incident Report for Snyk
Resolved
This incident has been resolved.
Posted about 1 month ago. Dec 19, 2018 - 09:57 UTC
Update
The issue is related to HSTS. If invite links don't work for you, there are currently two workarounds:
1. Delete the invite and send it again - the links will be with a different, working URL
2. Open the existing invite link in "Incognito/Private" window of the browser
Posted about 1 month ago. Dec 12, 2018 - 09:53 UTC
Monitoring
Our email provider is having some issues, some functionality like member invite links might not work. We are investigating the issue.
Posted about 1 month ago. Dec 12, 2018 - 07:52 UTC